Home / Cyber Security / Urgent Fix For Intel Users

Urgent Fix For Intel Users

Leslie Whitten

If you are an Intel user, you need to know that Intel’s security team has found a vulnerability in the CMSE (Converged Security and Management Engine).  The good news is that Intel has released a firmware update to mitigate the issue.  This issue has been deemed critical, so if this applies to you, get the update as soon as possible.  For more information on the  vulnerability and what to do depending on the platform you use, click here.